Categories
Linux Troubleshootings

VLC is not supposed to be run as root. Sorry. – Solution

Today i captured one tutorial using recordmydesktop utility on my backtrack and decided to view it but unfortunately backtrack 5 Linux didn’t include a good media player to do entertainment ๐Ÿ˜€ when you get bored with dirty work.

Anyways, i installed vlc using following command ;
aptitude install vlc

And tried to run vlc as root i got error on my terminal ;
vlc

VLC is not supposed to be run as root. Sorry.
If you need to use real-time priorities and/or privileged TCP ports
you can use vlc-wrapper (make sure it is Set-UID root and
cannot be run by non-trusted users first).

This error says straight forward vlc can not be run as root privileged user. What to do now? Don’t be panic. Here is the hacked solution ๐Ÿ˜€
vi /usr/bin/vlc
search for geteuid and replace it with getppid

Save file & Exit.

Now it should work, try to run it again ๐Ÿ˜‰

Note : This is a very bad practice to run certain application with administrative rights. Do it at your own risk! ๐Ÿ˜‰

Categories
Linux Troubleshootings

adb: No such file or directory

I call this Error in error, because it reports wrong error.

I got this error while i execute ./adb devices

ERROR :

adb: No such file or directory

Error itself is very confusing, because the file is exist there and it reports false error. Well after searching on googe, found i36 compatibility libraries are missing there which i installed it simply with apt-get.

FIX “adb: No such file or directory”

apt-get install ia32-libs

It worked great for me. Let me know if you are stuck in same trouble.

Categories
Linux Troubleshootings

NRPE daemon Network server bind failure (99: Cannot assign requested address)

This is because of you have set invalid IP in /etc/nrpe.cfg

e.g my correct IP of ethernet is 192.168.0.50

vi /etc/nrpe.cfg

add this;

server_address=192.168.0.50

now, you should see the following in /var/log/messages

tail -f /var/log/messages

Jul 7 11:03:35 hackersgarage nrpe[24067]: Starting up daemon
Jul 7 11:03:35 hackersgarage nrpe[24067]: Warning: Daemon is configured to accept command arguments from clients!
Jul 7 11:03:35 hackersgarage nrpe[24067]: Listening for connections on port 5666
Jul 7 11:03:35 hackersgarage nrpe[24067]: Allowing connections from: 192.168.0.X

Categories
HowTos Linux

mount: wrong fs type, bad option, bad superblock

If you are mounting NFS share on your Cpanel WHM Server and see this error, here is the solution;

yum install nfs-utils
/etc/init.d/portmap start
/etc/init.d/nfslock start

and now try to mount it. e.g;

mount 192.168.0.10:/some-share /mnt

Thats it!

Categories
HowTos Linux

The page isn’t redirecting properly

The page is not redirection properly screenshot
The page is not redirection properly Screenshot

If you are a web developer and recently launched website and you are not able to login in It is because of improper permissions on sessions directory defind in php.ini.

simple do;

chmod 777 -R /tmp/site-sessions

This will allow your web server to read/write sessions from this directory.

Personally one of my friend had problem and he lost his self for couple of hours. Hope it helps others too.

Categories
Android HowTos Linux

Installing Android SDK behind proxy requiring authentication

Today I was installing Android SDK on Linux behind authentication proxy server. I tried different settings but there was no way to put user,password in proxy settings. In the end finally I found a workaround to install Squid Proxy on my LinuxMint 11 (Ubuntu based distro) and set proxy to local and it worked enormous!

wget http://http.us.debian.org/debian/pool/main/d/db/libdb5.1_5.1.25-11_amd64.deb
wget http://http.us.debian.org/debian/pool/main/d/db/libdb5.1-dev_5.1.25-11_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/s/squid-langpack/squid-langpack_20110214-1_all.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/s/squid/squid-common_2.7.STABLE9-4ubuntu2_all.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/s/squid/squid_2.7.STABLE9-4ubuntu2_amd64.deb
dpkg -i libdb5.1_5.1.25-11_amd64.deb ย libdb5.1-dev_5.1.25-11_amd64.deb squid-langpack_20110214-1_all.deb squid-common_2.7.STABLE9-4ubuntu2_all.deb squid_2.7.STABLE9-4ubuntu2_amd64.deb

vi /etc/squid/squid.conf

search for โ€˜cache_peer and ย put following around there

cache_peer 192.168.0.100 parent 8080 0 no-query default login=username:password
never_direct allow all

Make a note of following :

Real Proxy Server = 192.168.0.100
8080 = proxy server port
Username = Your authentication proxy user name.
Password = Your Password for proxy.

And restart squid
service squid stop
service squid start

Now define following in your application it will work like a charm;

Proxy Server IP : 127.0.0.1
Port : 3128

Hope that works same for you.